How can i remove a host from pool?



  • this is a task that is stuck for the host having the patch update issue

    0_1515456279675_ab3673e9-d5fb-4ff1-bf0a-ed999b792ea7-image.png



  • You just need to rename the pool. This can be done from within XO.



  • i renamed the pool already..just by editing the name
    or is there something else i need to do?
    so that part is done but this patch update issue is what i will like to fix
    not sure what the issue is coming from



  • Not sure why you are having issues patching on this one server. Has the server been rebooted since you removed the other host? Was this server the primary when you had the single pool.



  • yes it was the primary when i had the pool
    and yes it has been rebooted

    i may try to reboot again



  • Suggest that you try capturing the XS logs again if you are still having issues. Not sure that the one posted above is pertinent to this patching issue.



  • it is
    check the screesnhot and the error message
    you will see rdd stuff in both



  • When I use my googlefoo and search on rrd_updates, I get stuff related to performance metrics. <shrug>



  • ok i just restarted the host again and tried to install the patches in XO
    Here is screenshot of error message

    0_1515460405592_fdfa8a3e-a5cd-4f15-851f-e7e683f6cdcd-image.png

    Jan  8 20:16:25 xenserver105 xapi: [debug|xenserver105|1682 INET :::80||xapi] Got the jsonrpc body: {"jsonrpc":"2.0","method":"event.from","params":["OpaqueRef:51b13d8f-6eb5-30ba-3dba-acba2bb99bb3",["*"],"00000000000017717452,00000000000017716029",60.1],"id":0}
    Jan  8 20:16:30 xenserver105 xapi: [debug|xenserver105|1683 INET :::80||xapi] Here in jsoncallback
    Jan  8 20:16:30 xenserver105 xapi: [debug|xenserver105|1683 INET :::80||xapi] Got the jsonrpc body: {"jsonrpc":"2.0","method":"task.create","params":["OpaqueRef:51b13d8f-6eb5-30ba-3dba-acba2bb99bb3","[XO] Xapi#getResource /rrd_updates",""],"id":0}
    Jan  8 20:16:30 xenserver105 xapi: [debug|xenserver105|1683 INET :::80||xapi] Got the jsonrpc body: {"jsonrpc":"2.0","method":"task.create","params":["OpaqueRef:51b13d8f-6eb5-30ba-3dba-acba2bb99bb3","[XO] Xapi#getResource /rrd_updates",""],"id":0}
    Jan  8 20:16:30 xenserver105 xapi: [ info|xenserver105|1683 INET :::80|task.create D:8b315e69c18f|taskhelper] task [XO] Xapi#getResource /rrd_updates R:76b7f40ad8ff (uuid:5178101e-62ca-bd89-9453-9c3c29c7f9c0) created (trackid=de95b1830908300f6a5aee6d7fda2b33) by task D:8b315e69c18f
    Jan  8 20:16:30 xenserver105 xapi: [ info|xenserver105|1684 INET :::80||taskhelper] task [XO] Xapi#getResource /rrd_updates R:76b7f40ad8ff forwarded (trackid=de95b1830908300f6a5aee6d7fda2b33)
    Jan  8 20:16:30 xenserver105 xapi: [debug|xenserver105|1684 INET :::80|[XO] Xapi#getResource /rrd_updates R:76b7f40ad8ff|xapi] hand_over_connection GET /rrd_updates to /var/lib/xcp/xcp-rrdd.forwarded
    Jan  8 20:16:30 xenserver105 xapi: [debug|xenserver105|1684 INET :::80|[XO] Xapi#getResource /rrd_updates R:76b7f40ad8ff|taskhelper] forwarded task destroyed
    Jan  8 20:16:30 xenserver105 xapi: [debug|xenserver105|1685 INET :::80||xapi] Here in jsoncallback
    Jan  8 20:16:30 xenserver105 xapi: [debug|xenserver105|1685 INET :::80||xapi] Got the jsonrpc body: {"jsonrpc":"2.0","method":"task.destroy","params":["OpaqueRef:51b13d8f-6eb5-30ba-3dba-acba2bb99bb3","OpaqueRef:76b7f40a-d8ff-0636-46c9-c963a3a7693f"],"id":0}
    Jan  8 20:16:30 xenserver105 xapi: [debug|xenserver105|1685 INET :::80||xapi] Got the jsonrpc body: {"jsonrpc":"2.0","method":"task.destroy","params":["OpaqueRef:51b13d8f-6eb5-30ba-3dba-acba2bb99bb3","OpaqueRef:76b7f40a-d8ff-0636-46c9-c963a3a7693f"],"id":0}
    Jan  8 20:16:30 xenserver105 xapi: [debug|xenserver105|1686 INET :::80||xapi] Here in jsoncallback
    Jan  8 20:16:30 xenserver105 xapi: [debug|xenserver105|1686 INET :::80||xapi] Got the jsonrpc body: {"jsonrpc":"2.0","method":"event.from","params":["OpaqueRef:51b13d8f-6eb5-30ba-3dba-acba2bb99bb3",["*"],"00000000000017717460,00000000000017716029",60.1],"id":0}
    Jan  8 20:16:30 xenserver105 xapi: [debug|xenserver105|1686 INET :::80||xapi] Got the jsonrpc body: {"jsonrpc":"2.0","method":"event.from","params":["OpaqueRef:51b13d8f-6eb5-30ba-3dba-acba2bb99bb3",["*"],"00000000000017717460,00000000000017716029",60.1],"id":0}
    Jan  8 20:16:30 xenserver105 xapi: [debug|xenserver105|1687 INET :::80||xapi] Here in jsoncallback
    Jan  8 20:16:30 xenserver105 xapi: [debug|xenserver105|1687 INET :::80||xapi] Got the jsonrpc body: {"jsonrpc":"2.0","method":"event.from","params":["OpaqueRef:51b13d8f-6eb5-30ba-3dba-acba2bb99bb3",["*"],"00000000000017717462,00000000000017716029",60.1],"id":0}
    Jan  8 20:16:30 xenserver105 xapi: [debug|xenserver105|1687 INET :::80||xapi] Got the jsonrpc body: {"jsonrpc":"2.0","method":"event.from","params":["OpaqueRef:51b13d8f-6eb5-30ba-3dba-acba2bb99bb3",["*"],"00000000000017717462,00000000000017716029",60.1],"id":0}
    


  • I don't see any errors in that log.

    Anything in the xo logs under settings > logs?



  • you are right
    here is what i see

    0_1515462350113_5fcddef6-deae-4830-808f-d4f22cda69fa-image.png

    What is fix for this
    i do not have an SR

    that is the problem, it still thinks of multiple host pool..but this is now a single host pool
    and i don't know why it need SR
    i do not need SR for a single host pool



  • @macaxenguy You probably just need to set the default SR. Are you using local storage?



  • @danp
    yes

    how come i did not this issue with other host i removed from the pool?



  • Also you can click the eyeball icon for details on each log entry.





  • I think the problem is the old pool

    i need a way to correctly remove from old pool and start from new single self pool
    @olivierlambert any help here?



  • Go to Home > Storages and make sure that you have a default SR set.

    0_1515465323419_a00cdf2a-3b41-473a-aee9-b6bca7535910-image.png



  • @danp
    You are right no default SR
    how do i set it?

    0_1515465440224_ec6f0268-5b38-45db-89ff-fa08459d44a0-image.png



  • If you see that "Default SR" designator, then it mean that particular SR is your default SR. To change it to another SR, hover over the desired SR and then click the drive icon.

    0_1515466600365_d81cab51-84b4-4067-8383-8d29a0c8fb5e-image.png



  • @macaxenguy Are you supposed to have two SRs named "Local storage"?


Log in to reply