Error restoring Delta backups



  • Hello,

    first thing: good job guys for xen-orchestra !

    i'm trying XO (from sources) with deltas backup.
    I have a xenserver 6.5 with local SR ans NFS SR.
    I've made a full backup of an XP Client (which is located on NFS SR) on a NFS Share. Then, i've made 2 others delta backup.
    So i've deleted the original VM and then I've tried to restore the full backup but i'm getting errors.
    The VM is created without disks.

    what is wrong?



  • What errors are you getting? Could you copy/paste them here?



  • Hi Julien,

    on the screen, i have 2 popups
    One blue with "VM Import started: Starting the VM import"
    and the Orange one with "Imports a delta backup from a remote point: The action failed for unkown reason"

    thanks
    Pierre



  • You should have more information on the server's console.



  • here is the log:

    xo:api admin@admin.net | remote.getAll(...) [5ms] ==> array +143ms
     xo:api admin@admin.net | acl.getCurrentPermissions(...) [8ms] ==> object +3s
     xo:api admin@admin.net | remote.getAll(...) [20ms] ==> array +7s
     xen-api root@172.16.0.2: task.create(...) [21ms] ==> string +31ms
     xo:xapi task created: VM import () +1ms
     xen-api root@172.16.0.2: event.from(...) [10s] ==> object +88ms
     xen-api root@172.16.0.2: event.from(...) [187ms] ==> object +189ms
     xo:api admin@admin.net | vm.importDeltaBackup(...) [355ms] =!> XapiError: INTERNAL_ERROR(Import.IFailure(2)) +35ms
     xo:perf blocked for 46ms +2ms
     xen-api root@172.16.0.2: task.destroy(...) [18ms] ==> string +19ms
     xo:xapi task destroyed: VM import () +0ms
     xen-api root@172.16.0.2: event.from(...) [99ms] ==> object +54ms
     xo:api admin@admin.net | remote.getAll(...) [6ms] ==> array +67ms
     xo:api admin@admin.net | acl.getCurrentPermissions(...) [9ms] ==> object +3s
     xo:api admin@admin.net | remote.getAll(...) [9ms] ==> array +2s](undefined)[undefined](undefined)
    

    thanks



  • What git branch are you using? stable or next-release?



  • stable



  • @olivierlambert Could this error be related to the metadata import?



  • @pbriec Just to explain the situation: we are having a lot of issues from Xen API with importing the metadata of VM, which is something the backups are based on, this will be replaced in the next release.



  • Indeed, this sounds as a meta data import problem.



  • Ok,
    So, it's specific to my system or xo app?



  • It's a bug on XenServer side. I don't know the trigger, but it happens sometimes (often). That's why we removed metadata in the next version 🙂



  • @pbriec This issue should not occur if you import on the same pool you exported your VM from.

    I am sorry for this issue, I hope you have not lost any data because of it, hopefully this will not happen anymore with the next version 😕



  • Hi,

    i only have one pool.
    This VM was stored on the NFS SR, and the backup on the same NAS on a NFS Share.
    I've also tried to backup/restore a VM stored on the local SR, it's the same.



  • What you could try to check the XenServer behavior: just copy the xva file in your host, and try:

    xe vm-import filename=filename.xva --metadata --force=true

    Tell me what you got!



  • Here is the log

    [root@xen-lycee ~]# xe vm-import filename="20160126T162704Z_Windows XP - client4.xva" --metadata --force=true
    This operation cannot be performed because the specified VDI could not be found in the specified SR
    sr: cfd22f96-2e92-3e6f-45ec-6ca6049b2216 (NFS virtual disk storage)
    location: c68756f2-38e2-4b06-b5df-0334d2dff556
    [root@xen-lycee ~]#
    


  • Sorry, it's just --force



  • [root@xen-lycee ~]# xe vm-import filename="20160126T162704Z_Windows XP - client4.xva" --metadata --force
    The server failed to handle your request, due to an internal error.  The given message may give details useful for debugging the problem.
    message: Import.IFailure(2)
    [root@xen-lycee ~]# 
    

    The VM appears in XenCenter without disks and networking configuration.



  • Great. Really. Great. The API told you it fails but in fact it's imported.

    How can we code something on top of this if error message aren't relevant at all 😕

    I already reported the issue on Xenserver bug tracker. Sometimes, it works, but I don't know when or how to trigger it (sometimes a reboot, sometimes not).

    In the worst case, your backups aren't useless: you'll have to import the vhd manually with xe.

    Otherwise, the new release will make every new backup without using metadata files (sorry, we believed this should work in the XAPI, because it's pretty basic, but it seems not).



  • Hi Olivier & Julien,

    is the issue supposed to be resolved? I've not seen in the changelog
    I've upgraded to 4.13 and i'm wondering if there are problems.

    I've tried to make tests on a fresh windows client.
    No earlier backup

    In the job manager, the task is running fine and indicated as Finished.
    In the nas storage, i've looked at the backup.
    No xva at all, only the json file. In the vdi directory, i've got a xxxx_full.vhd that is not a full backup (1.98Go)
    I've tried in another VM, the same.
    No first full backup and no xva

    Pierre


Log in to reply