Move a server from its own pool to another pool as a host.



  • Hi Guys,

    sorry if this is a noob question, but I'm trying to work out how to remove a server from its own pool (obviously its a pool master) so that I can attache it to another pool as a second host.

    I've got both machines added to XO and can see them there, as two pools, two machines, but I can't for the life of me work out how to remove it from its own pool and add it to the other master.

    I stumbled across the detach button, but that threw an error saying it can't eject the machine and other than that, the instructions I've found talk about pressing buttons I simply don't see.

    https://xen-orchestra.com/forum/topic/635/create-pool for example, talks about pressing an "add host" button that I can't find anywhere.

    Are there any docs that would help me here? How should one go about this?

    Ta
    Peter.



  • When viewing the pool, you should see these buttons in the upper right --

    Inkedfirefox_2019-01-24_22-16-43_LI.jpg

    Click the one I marked in red to add a host to the pool.



  • @Danp thank you so much.. can't believe I missed that 😞

    However, still not there.

    When I click the button and select the server I get the following popup.

    58183af1-0a5c-429b-a1aa-f9013f86a7a3-image.png

    I went to the logs but I just get a spinner.

    Peter.



  • Please refresh the UI and be sure you are still connected to both hosts.



  • I refreshed the UI and made sure I could see VM's on both machine (I know I'll blow them away on the one I'm moving, that's cool), but now I get "Unknow error from the peer" when I try and move it.

    It is a much older machine, could that be the problem?



  • @pnunn said in Move a server from its own pool to another pool as a host.:

    It is a much older machine, could that be the problem?

    Could be. Suggest that you provide details on both machines.

    Also, what version of XS / XCP-ng is each server running?



  • They are both running the latest XCP-ng, installed a few days ago.

    I'll have to log into them and get the specs, there both in a data centre at the moment (the old one just thrown in the back of the cabinet for testing) :).

    The "old" one is reporting as

    0ff4c48b-dcf8-4589-b520-72d0fefcf7dd-image.png

    The "newer" one is a second hand google branded dell machine.

    138aeb8b-9872-447d-a846-4bcc2bf6bc6f-image.png

    Not sure if that tells you anything useful.



  • @pnunn
    OK, worked it out. I had a private lan with a vlan address of 0 on it.

    I removed all of the machines and removed the network, and have now managed to attache the server as a second host to the pool.

    Let the fun begin.

    🙂
    Peter.


Log in to reply